Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

v1.0.46 released: SubStr() and more expression operators


  • Please log in to reply
63 replies to this topic
Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004
NOTE: Although this release has been extensively tested and is not expected to break any existing scripts, several low-level enhancements were made. If you have any mission-critical scripts, it is recommended that you retest them and/or wait a few weeks for any bugs to get fixed.

Here are the changes for v1.0.46:

Added function SubStr(), which retrieves the specified number of characters at the specified position in a string.

Added assignment operators //=, .=, |=, &=, ^=, >>=, and <<=, which can be used anywhere in expressions. For example, Var .= "abc" appends the string "abc" to the end of Var's current contents.

Added full support in expressions for the operators ++, --, +=, -=, *=, and /= (formerly, they could be used only as the leftmost operator on a line). All assignment operators (especially ++ and --) behave in a C-like way when their result is used by some other operator.

Added the ternary operator (?:), which is a shorthand replacement for the if-else statement. For example, var := x>y ? 2 : 3 assigns the value 2 if x is greater than y; otherwise it assigns 3.

Added support for comma-separated expressions, which allow a single line to contain multiple assignments, function calls, and other expressions. [thanks PhiLho & Titan]

Improved variable declarations to support initialization on the same line. Note: A static variable's initialization occurs only once, before the script begins executing.

Improved line continuation to support all expression operators. For example, a line that starts with "?" or "+" is automatically merged with the line above it.

Improved performance of operators "." and ".=" to be as fast as the percent-sign method of appending a string.

Improved expressions to allow more types of consecutive unary operators such as !!Var. [thanks Laszlo]

Changed Critical to check messages less often (20 vs. 10ms), which improves the reliability of frequently-called OnMessage functions. [thanks Majkinetor]

Changed: A variable named simply "?" is no longer valid in expressions due to the new ternary operator.

Fixed hotkeys to support ":::" (colon as a hotkey) and ": & x" (colon as a hotkey prefix).

Fixed the installer to remove psapi.dll from the AutoHotkey folder (except on Windows NT4). This avoids a conflict with Internet Explorer 7. [thanks to all those who reported it]

-----

In case anyone is wondering, I chose SubStr() as the name rather than StrSub() or StrMid() because naming functions consistently doesn't seem as valuable as good readability and conciseness. Furthermore, many other languages have a SubStr() function that behaves the same way, which reduces the learning curve for people coming from some other language to AutoHotkey (or vice versa).

Laszlo
  • Moderators
  • 4713 posts
  • Last active: Mar 31 2012 03:17 AM
  • Joined: 14 Feb 2005
Wow! These changes should warrant a new subversion number. How about v1.1.0? Scripts will look drastically different with the new syntax enhancements...

toralf
  • Moderators
  • 4035 posts
  • Last active: Aug 20 2014 04:23 PM
  • Joined: 31 Jan 2005
Hi Chris,
Thanks for the new features. I will use several of them for sure.
Ciao
toralf
 
I use the latest AHK version (1.1.15+)
Please ask questions in forum on ahkscript.org. Why?
For online reference please use these Docs.

ahklerner
  • Members
  • 1386 posts
  • Last active: Oct 08 2014 10:29 AM
  • Joined: 26 Jun 2006
Chris.....You are making this better all of the time.....

foom
  • Members
  • 386 posts
  • Last active: Jul 04 2007 04:53 PM
  • Joined: 19 Apr 2006
Wow after seeing a new version is released and reading that expression way of concatenating is as fast as the deref way i had to do a little benchmarking.
setbatchlines -1
#noenv

DllCall("QueryPerformanceCounter", "Int64 *", CounterBefore)
loop, 1000
{
x .="xxxxxxxxxxxxxxxxxxxxxxxxxxx"
;x=%x%xxxxxxxxxxxxxxxxxxxxxxxxxxx
}
DllCall("QueryPerformanceCounter", "Int64 *", CounterAfter)
MsgBox % "Elapsed QPC time // 1000 is " . (CounterAfter - CounterBefore)//1000
; deref method ~ 6000
; old expression method ~ 90000 .~ 12 times slower
; new expression method ~ 7000 .Not exactly like deref. But still wow:"Warp Speed Twelve, Mr. La Forge":lol:

Thank Chris. Keep up the hard work. :)

SKAN
  • Administrators
  • 9115 posts
  • Last active:
  • Joined: 26 Dec 2005
Posted Image

I never expected so much! Many thanks .. :D

Special thanks for the SubStr(). I was craving for it for a long time!

In case anyone is wondering, I chose SubStr() as the name rather than StrSub() or StrMid() because naming functions consistently doesn't seem as valuable as good readability and conciseness.


IMHO, SubStr() is very much consistent with InStr(), and I can forsee the usage of InStr() as a SubStr() parameter.

Regards, :)
kWo4Lk1.png

PhiLho
  • Moderators
  • 6850 posts
  • Last active: Jan 02 2012 10:09 PM
  • Joined: 27 Dec 2005

Wow! These changes should warrant a new subversion number. How about v1.1.0? Scripts will look drastically different with the new syntax enhancements...

That's funny, while reading this long list of features, I was thinking exactly the same thing... :-)
I will have to update my lexer for Scintilla...

Lot of hard work here, I download it immediately to test it!
And as Goyyah pointed out, the new function is at least consistent with its brother, InStr()...
Posted Image vPhiLho := RegExReplace("Philippe Lhoste", "^(\w{3})\w*\s+\b(\w{3})\w*$", "$1$2")

Thalon
  • Members
  • 641 posts
  • Last active: Jan 02 2017 12:17 PM
  • Joined: 12 Jul 2005
I can just say: wow!

corrupt
  • Members
  • 2558 posts
  • Last active: Nov 01 2014 03:23 PM
  • Joined: 29 Dec 2004
I'm glad I waited a bit longer before updating a few existing scripts. Thanks for the improvements :) .

In case anyone is wondering, I chose SubStr() as the name rather than StrSub() or StrMid() because naming functions consistently doesn't seem as valuable as good readability and conciseness.

The only drawback for me is that I frequently use the index in a help file as a quick reference. I could always use the Contents tab I guess... but I never do ;) .

JSLover
  • Members
  • 920 posts
  • Last active: Nov 02 2012 09:54 PM
  • Joined: 20 Dec 2004

The only drawback for me is that I frequently use the index in a help file as a quick reference.

...I say name stuff the way that sounds best...like SubStr (substring) vs StrSub (string sub??? tract? stitute?)...but then add index entries like...
StrSub (see SubStr)...clicking on the entry would take you to the help page with the correct name...so name for best-looking/sounding, but patch it up in the index...I too only use the index for help...
Useful forum links: New content since: Last visitPast weekPast 2 weeks (links will show YOUR posts, not mine)

OMFG, the AutoHotkey forum is IP.board now (yuck!)...I may not be able to continue coming here (& I love AutoHotkey)...I liked phpBB, but not this...ugh...

Note...
I may not reply to any topics (specifically ones I was previously involved in), mostly cuz I can't find the ones I replied to, to continue helping, but also just cuz I can't stand the new forum...phpBB was soo perfect. This is 100% the opposite of "perfect".

I also semi-plan to start my own, phpBB-based AutoHotkey forum (or take over the old one, if he'll let me)
PM me if you're interested in a new phpBB-based forum (I need to know if anyone would use it)
How (or why) did they create the Neil Armstrong memorial site (neilarmstronginfo.com) BEFORE he died?

Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004

Wow! These changes should warrant a new subversion number. How about v1.1.0? Scripts will look drastically different with the new syntax enhancements...

That's funny, while reading this long list of features, I was thinking exactly the same thing... :-)

I was thinking the opposite because I thought not many people would care about C-like operators. I even delayed this release to add SubStr() to help justify making it a major vs. minor version number.

so name for best-looking/sounding, but patch it up in the index

Thanks for the idea. I've added index entries called "string: InStr()" and "string: SubStr()".

Tuncay
  • Members
  • 1945 posts
  • Last active: Feb 08 2015 03:49 PM
  • Joined: 07 Nov 2006
Chris, thx for the changes you made in this version. I like this update, 'cauze SubStr() and some operators, especially .=.
But on the other hand, adding some of the operators is a bad idea. I do not understand why you have introduced the ternary operator ?: and command separated expressions? They lead to badly readable scripts. Ok, its a lot fewer to write, but I don't like that.

No signature.


Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004

I do not understand why you have introduced the ternary operator ?: and command separated expressions? They lead to badly readable scripts.

It's a matter of personal scripting style. Some people crave the ability to write related expressions all on one line. In addition, the ternary operator can simplify some kinds of expressions, and in some cases gives better performance.

hs2
  • Members
  • 11 posts
  • Last active: Apr 03 2012 09:05 AM
  • Joined: 25 Feb 2005
@Chris: You are my number one hero !

@Tuncay: If you don't like it - don't use it ;)

HS2

SKAN
  • Administrators
  • 9115 posts
  • Last active:
  • Joined: 26 Dec 2005

adding some of the operators is a bad idea. I do not understand why you have introduced the ternary operator ?: and command separated expressions? They lead to badly readable scripts.


I had faced instances where my script had a specific need to nullify the variable contents.

Maybe initialising variables one-a-line might be readable for others. But nullifying existing variables the same way looks ugly and will make the code unneccessarily long. Like:

2GuiClose:
 Gui, 2:Destroy
 Var1=
 Var2=
 Var3=
 Var4=
 Var5=
 Var6=
Return

Instead of:

2GuiClose:
 Gui, 2:Destroy
 Var1:="" , Var2:="" , Var3:="" , Var4:="" , Var5:="" , Var6:="" ; Resetting Vars
Return

JMHO .. Regards, :)

Edit:ListView is an another situation where I find it very useful:

LV_ModifyCol(1,"60 Integer"), LV_ModifyCol(2,"60 Integer"), LV_ModifyCol(3,"36 Center")
LV_ModifyCol(4,"36 Integer"), LV_ModifyCol(5,"36 Center"),  LV_ModifyCol(6,"100")

kWo4Lk1.png