Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

Can’t get my script running via autostart in Windows 10


  • Please log in to reply
3 replies to this topic
Kenika
  • Members
  • 50 posts
  • Last active: Oct 28 2015 02:53 PM
  • Joined: 08 Jul 2012

Hi there,

 

I just made the upgrade from Windows 7 to Windows 10. I have a .ahk script that I put as a link to the autostart folder in Win 7. No problem: The script started with the system. But now, in Win 10, that simple trick doesn’t seem to work anymore. I tried several things that I found in different threads like scheduling a task, but also this doesn’t work: the script has to be started manually.

Does anyone of you guys know how I can fix this and make my script start with the system’s start? Maybe a registry key? I have no idea…

 

Thanks!



GEV
  • Members
  • 1364 posts
  • Last active:
  • Joined: 23 Oct 2013

Have a look here and here

 

Try also this

if not A_IsAdmin
{
   Run *RunAs "%A_ScriptFullPath%"
   ExitApp
}
RegWrite, REG_SZ, HKEY_LOCAL_MACHINE, SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run, SCRIPT_NAME.ahk, "C:\Program Files\AutoHotkey\AutoHotkey.exe" D:\Scripts\SCRIPT_NAME.ahk

This could also be helpful:

http://www.howtogeek...-windows-vista/



LordXedis
  • Members
  • 11 posts
  • Last active: Dec 22 2015 04:12 AM
  • Joined: 18 Jul 2013

I ended up making a batchfile that starts AHK, and placed the short cut to the batchfile in the start folder and now AHK auto starts when I boot Windows 10.



customesports
  • Members
  • 1 posts
  • Last active: Dec 23 2015 02:30 PM
  • Joined: 22 Dec 2015

Thanks for this Lord Xedis, it now works for me