Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

Aaccents in Firefox searchfield



  • Please log in to reply
19 replies to this topic
Terka
  • Members
  • 53 posts
  • Last active:
  • Joined: 21 Aug 2007

To summarize it again:

:*:a1::
SendInput ěščřžýáíéúů
return

:*:a2::
clipboard:="ěščřžýáíéúů"
SendInput ^v ; common paste shortcut, may adjust for the language currently used
return

:*:a3::
SendInput % Chr(283) Chr(353) Chr(269) Chr(345) Chr(382) Chr(253) Chr(225) Chr(237) Chr(233) Chr(250) Chr(367)
return

:*:a4::
clipboard:=Chr(283) Chr(353) Chr(269) Chr(345) Chr(382) Chr(253) Chr(225) Chr(237) Chr(233) Chr(250) Chr(367)
SendInput ^v ; common paste shortcut, may adjust for the language currently used
return

I created one script with 4 abreviations a1, a2, a3, a4. Only abbreviations a3,a4 are working, I marked them bold:

ešcržýáíéúu
ešcržýáíéúu
ěščřžýáíéúů

ěščřžýáíéúů



Terka
  • Members
  • 53 posts
  • Last active:
  • Joined: 21 Aug 2007

Tried new default instal on my colleague's computer

http://ahkscript.org...ahk-install.exe

and the behavior is exactly the same.



space
  • Members
  • 520 posts
  • Last active:
  • Joined: 12 Aug 2014
It really sounds like an encoding problem. Double check it: Open the script in notepad, choose File, Save As, and you should see the Encoding - choose UTF-8, save. Reload and try again. Do you have any clipboard tools running?

Terka
  • Members
  • 53 posts
  • Last active:
  • Joined: 21 Aug 2007
✓  Best Answer

It helped! The text editor im using - older version has some error in encoding and showing wrong encoding type.

Now i have to convert all my scripts to proper encoding.

All guys, thank you very much!



space
  • Members
  • 520 posts
  • Last active:
  • Joined: 12 Aug 2014
Mystery solved!