Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

Yesterday Auto it winspy worked and today



  • Please log in to reply
3 replies to this topic
TheProj
  • Members
  • 3 posts
  • Last active: Oct 30 2015 02:21 PM
  • Joined: 26 Oct 2015

Does not see any ClassNN, visible text, all text? Only window title, class, process, color, and position.

 

Nothing changed. Tried reinstalling and other window info apps. It is only doing it to VMware vCenter Converter application.

 

Tried on a fresh machine and still nada.

 

Any ideas? Hows this even possible to see QWidgets and their associated numbers yesterday and not today?

 

Portion of the script that was working yesterday and as you can see I was getting QWidget details yesterday (importing from excel file setup and loop before this section):

 

SetControlDelay -35
WinWaitActive, VMware vCenter Converter Standalone
ControlClick, QWidget2
;Convert Machine
ControlClick, VMware vCenter Converter Standalone
WinWaitActive, VMware vCenter Converter Standalone, 2
 
ControlClick, QWidget9, VMware vCenter Converter Standalone
sleep, 1000
WinWaitActive, Conversion
;ControlClick, QWidget37, Conversion
;sleep, 1000
 
 
 
; Enter A and enter five times
ControlClick, QWidget37, Conversion
Sleep 150
ControlSetText, QWidget37, , Conversion
Send ^a%VMName%{Del}
Sleep 100
 
ControlClick, QWidget34, Conversion
Sleep 150
;ControlSetText, QWidget34 , Conversion
Send ^a%B_stored%{Del}
Sleep 100
 
ControlClick, QWidget32, Conversion
Sleep 500
Send ^a%C_stored%{Del}
Sleep 100
 
ControlClick, QWidget4, Conversion
WinWaitActive, Converter Security Warning,
ControlClick, QWidget3, Converter Security Warning

 

#############################################

Below is all that is visible today: 

 

VMware vCenter Converter Standalone
ahk_class QWidget
ahk_exe converter.exe
 
Absolute: 611, 288 (less often used)
Relative: 563, 223 (default)
Client: 555, 192 (recommended)
 
ClassNN:
Text: VMware vCenter Converter Standalone
Color: FFFFFF (Red=FF Green=FF Blue=FF)
x: 0 y: 0 w: 976 h: 615
Client: x: -8 y: -31 w: 960 h: 576
 
x: 48 y: 65 w: 976 h: 615
Client: w: 960 h: 576
 
 
Thanks!
 

 



TheProj
  • Members
  • 3 posts
  • Last active: Oct 30 2015 02:21 PM
  • Joined: 26 Oct 2015

Ok. So I get home vpn in, launch rdp, log in to same server, run autohotkey and spy. Guess what my script works and Window Info can see the values now?!?

 

So MacBook, Windows 10 vm on Fusion works on the same server over RDP.

 

My, at work physical, Windows 7 desktop didn't work whether I used rdp, VMware remote console, or dameware to the same vm?!? Even tried another fresh Windows 10 vm to rdp in to the same server but nada. 

 

I was going to say some crazy thing with VMware tools but the fresh W10 vm didn't work either when at work. Yup check UAC.



TheProj
  • Members
  • 3 posts
  • Last active: Oct 30 2015 02:21 PM
  • Joined: 26 Oct 2015
✓  Best Answer

Solved suckaaaaasss. Who would have ever thought that just having the virtual keyboard running would solve my problems, and doesnt have to be used to type just running!

 

If you got windows info problems

I feel bad for you son

I got 99 problems

but ahk aint one!

 

Well I tried all kinds of Get this Get that scripts, ahk versions 1.x-2.A, AHK tools/studio, and anything else that seemed to have even the slightest possibility. Used procmon and process hacker and noticed tabtip running when at home. I bet it senses the macbook pro touchpad and see it as a "tablet" interface and automattically runs it in the background. Well at work it is a physical mouse, no touchpad, so tabtip never gets executed. Thank you Tablet and Handrwiting panel! As you have freed Windows Info Spy and are squirting all your glory text onto my screen. Launched it on the desktop (Windows 7),another server(Server 2012 r2), and another Windows 10 (VM) and voila. Windows Info spy got real loose with her data.

 

Life will be ok...... it will be ok...

 

Lol

Sorry, just happy I dont have to "Send tab down A% x Z=564" just controlclick qwidgets once again!



Exaskryz
  • Members
  • 3249 posts
  • Last active: Nov 20 2015 05:30 AM
  • Joined: 23 Aug 2012

Glad you figured that out. I don't think that would have ever crossed my mind. And thank you very much for reporting back with your solution so that others who may have the problem might find your thread.