Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

AutoHotKey tmbundle


  • Please log in to reply
4 replies to this topic
n00ge
  • Members
  • 37 posts
  • Last active: Jul 20 2010 10:49 PM
  • Joined: 28 Sep 2007
I have created a very simple AutoHotKey bundle for e-texteditor/textmate. It isn't very well developed (kind of hacked from other bundles) but it's a start. Feel free to download and share updates.

http://www.creativer...e/ahkbundle.zip

n00ge
  • Members
  • 37 posts
  • Last active: Jul 20 2010 10:49 PM
  • Joined: 28 Sep 2007
This bundle has been updated a bit with better syntax highlighting and a run command for the active script. I'll be making updates from time to time as well.

E-TextEditor is a great editor and the commands/snippets could integrate really well with AutoHotKey. Definitely worth checking out for anybody who hasn't seen it.

Ice_Tea
  • Members
  • 131 posts
  • Last active: Aug 25 2010 11:11 AM
  • Joined: 12 Jan 2008
Hey, I'm currently trying out the texteditor, I installed the bundle through the Bundle manager in the e-texteditor, but I don't seem to see the syntax highlightning, I tried putting urs in "C:\Documents and Settings\%USERNAME%\Application Data\e\Bundles" and it still didn't work.. what am I doing wrong? the text is simply black and white, no colours on the commands..

I really really like the "smooth look" in e-texteditor...

n00ge
  • Members
  • 37 posts
  • Last active: Jul 20 2010 10:49 PM
  • Joined: 28 Sep 2007
There's a more current bundle if you go to "Bundles > Manage Bundles" and grab the one from there. Try that and it should work for you.

I'm glad you like e. The guy working on it is really good at pushing out updates/bug fixes every 1-3 weeks. And once you get hooked on the Textmate-style snippets, it's tough to switch to something else.

Ice_Tea
  • Members
  • 131 posts
  • Last active: Aug 25 2010 11:11 AM
  • Joined: 12 Jan 2008

There's a more current bundle if you go to "Bundles > Manage Bundles" and grab the one from there. Try that and it should work for you.


I did that and it doesn't work :S
Posted Image

Edit: clicked at the little thingy on the bottom left and changed it to autohotkey, now it's only highlighting the commands and comments, seems like there aren't many colours on it, ah well I might try adding more colours, cause I really like the functions in e-texteditor... problem solved for now, thanks.