Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

Forum upgrade requires redoing your auto-login


  • Please log in to reply
11 replies to this topic
Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004
If you use the auto-login checkbox on the forum, you will notice that you have to log in and check the box again. This is probably due to a change in the forum's cookie format.

The same is also true of the German forum at http://s89775182.onlinehome.us/forum/

  • Guests
  • Last active:
  • Joined: --
Hi there is a problem with the cookies.
Phpbb2mysql_sid and phpbb2mysql_t get an expiry date of 1970-01-01 as soon as they are created as it seems. Is this normal?

The reason i write is because i noticed a while back that i cannot post as a logged in user anymore. I allways post as guest.

  • Guests
  • Last active:
  • Joined: --
Ohh btw i forgot to mention that i never check the "auto-login checkbox". So you might try to uncheck it and see if the problem occurs to you too.

foom
  • Members
  • 386 posts
  • Last active: Jul 04 2007 04:53 PM
  • Joined: 19 Apr 2006
Just a test with autologin checked.
Edit:
Hmm. Something is borked. With it checked i can post normally :/.

Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004
Usually this can be fixed by exiting your browser, deleting your AutoHotkey cookies, and then coming back to log in. If it still doesn't work, it's probably a system-specific issue, possibly proxy or ISP.

  • Guests
  • Last active:
  • Joined: --
Hmm i don't use a proxy.
My isp is t-com.de (biggest german isp). Many of german customers will use that to so this shouldn't be a problem either.
As i said the problem only occurs if i disable autologin. Btw i use Opera 9.10 if that helps.

Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004
Although this forum does have a few mods applied -- such as smart redirect, which after you logon takes you back to the page you were previously at -- it's nearly a standard phpBB forum in most ways. So you could try searching at http://www.phpbb.com/community/ to see if anyone else has this problem, and how they solved it.

If anyone else has problems with it, please let me know.

  • Guests
  • Last active:
  • Joined: --
Hmm after deleting operas sitespecific settings it seems to work again, allthought the setting don't differ from what they have been before. Anyway, sorry and thanks for letting me waste your time :).

foom
  • Members
  • 386 posts
  • Last active: Jul 04 2007 04:53 PM
  • Joined: 19 Apr 2006
Ohh no it did it again. Before posting the above i created a couple of post and deleted them and all worked fine. :cry:

foom
  • Members
  • 386 posts
  • Last active: Jul 04 2007 04:53 PM
  • Joined: 19 Apr 2006
One thing bothers me. If i select the "Log me in automatically each visit" option while logging in everything works. I dont know how anything on my end could cause this behavior.
What changes did you make to the cookie format?
Whats different when logging in with the autologin option and without?

Chris
  • Administrators
  • 10727 posts
  • Last active:
  • Joined: 02 Mar 2004

What changes did you make to the cookie format?

I didn't make any changes myself, nor do I think any of the mods did.

Whats different when logging in with the autologin option and without?

I'm not sure. I'd have to dig in to the source code or documentation, or search the phpBB forum.

foom
  • Members
  • 386 posts
  • Last active: Jul 04 2007 04:53 PM
  • Joined: 19 Apr 2006

What changes did you make to the cookie format?

I didn't make any changes myself, nor do I think any of the mods did.

Ohh first of all, i thought this topic was 2006 instead of 2005. :oops:

There is someone else on this forum who has this problem.
http://www.autohotke...topic13960.html
Note the topic date is roughly a year after this update. Might be a coincidence but might also be a hidden bug somewhere.
Second he uses firefox as he sais so it shouldn't be a browser problem.