Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

Notepad++ v6.2 , UDL & Syntax Highlighting


  • This topic is locked This topic is locked
48 replies to this topic
tidbit
  • Administrators
  • 2709 posts
  • Hates playing Janitor
  • Last active: Jan 15 2016 11:37 PM
  • Joined: 09 Mar 2008
Your list was ALMOST working for me. I was able to type A_I but as soon as I pressed n (for A_Index) the list disappeared.
I re-ordered it and removed a couple duplicates, it now works for me. I also added some more info+credits at the top.
removed due to forum bug, use someone elses whose yields better results.

rawr. be very afraid
*poke*
. Populate the AutoHotkey city. Pointless but somewhat fun. .


twiz
  • Members
  • 33 posts
  • Last active: Oct 08 2013 11:47 PM
  • Joined: 08 Nov 2011

Here is the list if someone want it.

Thanks for the info on the alphabetical order, but once you add the headers from the previous files to your Autohotkey.xml file, your list breaks because you have them A-Za-z. You'll either need to set ignoreCase="no" or re-order them.

Your list was ALMOST working for me. I was able to type A_I but as soon as I pressed n (for A_Index) the list disappeared.
I re-ordered it and removed a couple duplicates, it now works for me. I also added some more info+credits at the top.

Yours is broken too, after the A_* words. It needs to go AA, AB, AC, ..., AZ, A_, BA

I've confirmed that # and { don't work at all, even when the file ONLY contains those words, and I'm guessing that it's because additionalWordChar="" doesn't work, as previously mentioned. I've posted in Notepad++'s bug reports section about this.


I've forked infogulch's Github project and started updating them. They'll be merged back into infogulch's if he likes them (and IF I can figure out how to do that).
<!-- m -->https://github.com/t... ... Hotkey.xml<!-- m --> - Fixed Alphabetical order, 'Broken' words (# and {) are commented out at the end of the file.
<!-- m -->https://github.com/t... ... neLang.xml<!-- m --> - Infogulch/tidbit's list with some small tweaks/fixes/changes and using the 'default' styler.

vsub
  • Members
  • 1098 posts
  • Last active: Sep 28 2015 09:48 AM
  • Joined: 10 Nov 2011
Yes I saw that some of them still don't appear...as I said,NPP is really picky about the alphabetical sort order of the keywords.

But(I'm not 100% sure)the problem is only with keywords that start with A or non alphabetical character.

Btw does the hints also don't work or there is some special way to display them.
I'm pressing Ctrl+Shift+Space but not is appearing of for example WinActive(I'm currently trying twiz list)

twiz
  • Members
  • 33 posts
  • Last active: Oct 08 2013 11:47 PM
  • Joined: 08 Nov 2011

Btw does the hints also don't work or there is some special way to display them.
I'm pressing Ctrl+Shift+Space but not is appearing of for example WinActive(I'm currently trying twiz list)

Settings -> Preferences -> Backup/Auto-completion (tab) -> Tick "Function parameters hint on input"
http://i.imgur.com/fzPL7.png

I think I might need to re-fix my autocomplete file and turn off Function for some of them to complete regular command 'strings'.
func="no" doesn't help... as soon as you type the "," the hint turns off and doesn't offer a more detailed view. Possibly this means that paramSeparator="," is ALSO broken/ignored.

Does anyone have a link for the documentation of the Autocomplete .xml file?

Lexikos
  • Administrators
  • 9844 posts
  • AutoHotkey Foundation
  • Last active:
  • Joined: 17 Oct 2006

no idea why would anyone want autocomplete for single character

I don't know about Notepad++, but in SciTE the 1 and 2 character autocomplete entries are necessary to prevent it from autocompleting to a longer word - e.g. "in" to "IniDelete". How useful it is depends on how "automatic" the autocomplete function is configured to be.

aRt)Y
  • Members
  • 447 posts
  • Last active: Oct 03 2013 08:40 PM
  • Joined: 17 Nov 2011
Still doesn't work.
I've added the autohotkey.xml in the install/API folder and the userdefinelanguage.xml in the appdata folder of notepao++.

vsub
  • Members
  • 1098 posts
  • Last active: Sep 28 2015 09:48 AM
  • Joined: 10 Nov 2011
Did you tried
where n++ is installed\plugins\APIs\Autohotkey.xml

aRt)Y
  • Members
  • 447 posts
  • Last active: Oct 03 2013 08:40 PM
  • Joined: 17 Nov 2011
That's what I meant with install path.
C:\Program Files (x86)\Notepad++\plugins\APIs\AutoHotkey.xml
..\AppData\Roaming\Notepad++\userDefineLang.xml

By the way, why can't I see the code/quotes posted by the other users? They seem emty, on all three browsers.

vsub
  • Members
  • 1098 posts
  • Last active: Sep 28 2015 09:48 AM
  • Joined: 10 Nov 2011
Yes,there seems to be some bug with the forum or during the forum update they got completely deleted somehow....it's just empty space now

genmce
  • Members
  • 144 posts
  • Last active: May 21 2015 03:09 PM
  • Joined: 10 Jan 2009
Where to put the two xml files, from above post 17.
I am running 6.2 and on a liberkey portable install...
I tried dropping the files in the Notepad++ folder that contains the .exe.
I restarted notepad++ and it is not listed in the language menu item.

KeyMce/GenMce - mackie emulator for pc keyboard/Convert your controller to mackie.
Midi I/O - Want to play with midi/ahk? links dead.. pm me


fischgeek
  • Moderators
  • 1074 posts
  • Last active: Jul 07 2015 06:27 PM
  • Joined: 20 Apr 2009
Post removed.

jNizM
  • Members
  • 928 posts
  • Last active: Jan 12 2018 09:23 AM
  • Joined: 01 Aug 2012
@genmce

userDefineLang.xml in main folder (Notepad++)
- start Npp
- click on Menu Language
- add custom one
- Import your uDL
- restart Npp

AutoHotkey.xml in API folder (Notepad++\plugins\APIs)
- start Npp
- settings
- preferences
- Auto-Completion
- Enable auto-completion
[AHK] 1.1.27.04 x64 Unicode | [WIN] 10 Pro (Version 1709)
My GitHub Profile | Donations are appreciated if I could help you

aRt)Y
  • Members
  • 447 posts
  • Last active: Oct 03 2013 08:40 PM
  • Joined: 17 Nov 2011
I followed the steps as you said but the autocomplete function still doesn't work.
Neither do the colours.

C:\Program Files (x86)\Notepad++\userDefineLang.xml
C:\Program Files (x86)\Notepad++\plugins\APIs\AutoHotkey.xml

genmce
  • Members
  • 144 posts
  • Last active: May 21 2015 03:09 PM
  • Joined: 10 Jan 2009
@jNizM
Tried - failed to import error.Tried your original file on 1st post - it worked for syntax highlight.What about infogulches files?

KeyMce/GenMce - mackie emulator for pc keyboard/Convert your controller to mackie.
Midi I/O - Want to play with midi/ahk? links dead.. pm me


vsub
  • Members
  • 1098 posts
  • Last active: Sep 28 2015 09:48 AM
  • Joined: 10 Nov 2011
Does anyone else have this problem.
In NPP click on the icon for new tab\file,change the language to autohotkey(or any user defined language)and when you try to save,it will not save the file with the extension for the language.

The drop-down list in Save as type,doesn't contain ahk.