Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate
Photo

[1.1.09.03] Keyboard Accelerators in Gui menus don't work anymore



  • Please log in to reply
3 replies to this topic
Ragnar
  • Members
  • 68 posts
  • Last active: Aug 26 2015 12:18 PM
  • Joined: 02 Oct 2006

Since v1.1.09.03, the keyboard shortcuts are no longer detected automatically, if created via Menu command in conjunction with Gui Menu. In previous versions they work without problems.

If I launch following test script and press Ctrl+O, no MsgBox appears:

Menu, FileMenu, Add, &Open`tCtrl+O, MenuFileOpen
Menu, FileMenu, Add, E&xit, MenuHandler
Menu, HelpMenu, Add, &About, MenuHandler
Menu, MyMenuBar, Add, &File, :FileMenu
Menu, MyMenuBar, Add, &Help, :HelpMenu
Gui, Menu, MyMenuBar
Gui, Show, w200 h200
Return

MenuFileOpen:
MenuHandler:
Msgbox
Return

 

 



fincs
  • Moderators
  • 1662 posts
  • Last active:
  • Joined: 05 May 2007
Confirmed - doesn't work for me either.

Lexikos
  • Administrators
  • 9844 posts
  • AutoHotkey Foundation
  • Last active:
  • Joined: 17 Oct 2006
This will be fixed; however, it only occurs if the Gui itself has focus, which typically means there are no controls on the Gui. How often does that happen in real-world scripts?

Lexikos
  • Administrators
  • 9844 posts
  • AutoHotkey Foundation
  • Last active:
  • Joined: 17 Oct 2006
✓  Best Answer
Fixed in v1.1.09.04 (shortly after my previous post, but I didn't have time to announce it).