Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate

ARMA 2 ACRE + DXtory

  • Please log in to reply
3 replies to this topic
  • Members
  • 2 posts
  • Last active: Aug 21 2013 01:31 PM
  • Joined: 07 Aug 2013

Help, im trying to get this working. The goal is to make X1 (mouse button) hold while CapsLock is hold. Reason to do so is that in Arma with ACRE you can speak on voice chat (to ppl close to you) or on radio (with Capslock). But i can only set one button in DXtory to record my voice with push-to-talk. The script is working in other games (like Chivalry) but in arma i have strange problem.


When i run the script normally (without admin rights) i can use radio but the voice isnt recording.


When i run the script with admin rights i can't use radio and voice is recording.


Here's the script (simplest as i can be):

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

while GetKeyState("CapsLock", "P")  
    Click down X1
Click up X1


NVM got this working, the key was ~ before caps lock + run as admin, can be closed

  • Members
  • 845 posts
  • Last active: Jan 24 2016 05:24 PM
  • Joined: 08 Oct 2012

Hi is this what you mean?

if not A_IsAdmin
    Run *RunAs "%A_ScriptFullPath%"
SetWorkingDir, %A_ScriptDir%
#SingleInstance, force
#MaxThreadsPerHotkey 2
toggle = 0

CapsLock:: ; Toggle On/Off

Toggle := !Toggle
While Toggle{



  • Download link of my scripts on Autohotkey.com 2/10/2015 [DOWNLAND]
  • Contact Info:  https://github.com/floowsnaake //  FloowSnaake(A)gmail.com
  • IF you need Help send me a PM,Email or Post on Github

  • Quote by tank  Posted 29 September 2015 - 06:14 PM

  • "Eventually i will find a way to convert the DB back to PHPBB3. but i dont have the bandwidth right now. No one that has tried has had success. It is the Only way i can keep this open is if i could successfully convert it."

  • Members
  • 2 posts
  • Last active: Aug 21 2013 01:31 PM
  • Joined: 07 Aug 2013

Aight i didnt fix the problem apparently, whenever i wanna make ACRE (radio) button to make anything else than transmitting through radio, its stops working - it doesnt work at all when i dont run it as admin, but when i do - it works in Arma but not in Teamspeak (i dont hear beep and it doesnt transmit, but ingame i can see that i use radio). Any fix ?

  • Members
  • 59 posts
  • Last active: Sep 14 2013 11:57 PM
  • Joined: 13 Aug 2013

untested and I have no idea if this will work for you... but I hope it gives you some ideas.




  SendInput, {X1Button down}

  Keywait, Capslock

  SendInput, {X1Button up}



since this stanza will run as a seperate thread, it should wait indefinately for you to release the capslock.

check the help file for 'KeyWait' options.


Using the Capslock key to direct the X1 button to one routine or another is a different matter.


There is probably something I am overlooking, seems way to simplistic to me.

Autohotkey needs to be run as admin, else it cannot send to the keyboard or move the mouse.  (at least in Win7 that is the case)