SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post a reply


In an effort to prevent automatic submissions, we require that you type the text displayed into the field underneath.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :| :mrgreen: :geek: :ugeek: :arrow: :angel: :clap: :crazy: :eh: :lolno: :problem: :shh: :shifty: :sick: :silent: :think: :thumbup: :thumbdown: :salute: :wave: :wtf: :yawn: :facepalm: :bravo: :dance: :beard: :morebeard: :xmas: :HeHe: :trollface: :cookie: :rainbow: :monkeysee: :monkeysay: :happybday: :headwall: :offtopic: :superhappy: :terms: :beer:
View more smilies

BBCode is ON
[img] is OFF
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Ovg » Today, 10:59

While this mod is active I can't set breakpoints anymore. Any suggestions will be appreciated.

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 23 Aug 2017, 14:21

sorry- there should be -- in front of ***Autoclose begin. I've updated it above. :oops:

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by derz00 » 23 Aug 2017, 13:21

Joe Glines wrote:I loved the idea and did some Googling. AutoIt had this implemented with SciTE. I just had to make a few very minor tweaks.
The below code will close out: {, [, (, ", and '

Here's what you need to do to try this:



Hi, I did that, and get this error:

Code: [Select all]GeSHi © Codebox Plus

C:\Users\ZCM\Documents\AutoHotkey\SciTE/UserLuaScript.lua:7: unexpected symbol near '*'
>Lua: error occurred while loading startup script


UserLuaScript.lua looks like this:

Code: [Select all] [Expand]GeSHi © Codebox Plus



***AutoClose Begin*** is line 7, which is the line of error. Any tips what I'm doing wrong??

Edit: Fixed, thanks Joe!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 23 Aug 2017, 08:32

Nice share there Joe!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 23 Aug 2017, 07:03

I loved the idea and did some Googling. AutoIt had this implemented with SciTE. I just had to make a few very minor tweaks.
The below code will close out: {, [, (, ", and '

Here's what you need to do to try this:
1) Export these lua files into your SciTE home directory
2) Open your UserLuaScript.lua script and add the following lines (in this order)

Code: [Select all]GeSHi © Codebox Plus

-- ***AutoClose Begin***
dofile(props['SciteUserHome'].."/Class.lua")
dofile(props['SciteUserHome'].."/Common.lua")
dofile(props['SciteUserHome'].."/AutoCloseBraces.lua")
EventClass:BeginEvents() -- Start up the events (Calls onstartup()).
-- ***AutoClose END

3) Restart SciTE

Here's a short video walking through the process

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by mankvl » 23 Aug 2017, 03:21

HotKeyIt wrote:
mankvl wrote:is there a way to make S4A autoclose { and ( ?

Probably:

Code: [Select all]GeSHi © Codebox Plus

#IfWinActive ahk_class SciTEWindow
~(::Send {)}{Left}
#IfWinActive

Ye, just was going to do smth like this, but this will only work if I have my main script running. Anyway thanks :)

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by HotKeyIt » 22 Aug 2017, 16:56

mankvl wrote:is there a way to make S4A autoclose { and ( ?

Probably:

Code: [Select all]GeSHi © Codebox Plus

#IfWinActive ahk_class SciTEWindow
~(::Send {)}{Left}
#IfWinActive

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 22 Aug 2017, 14:22

Write a plugin ;)
never thought of making one lol

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by mankvl » 22 Aug 2017, 12:51

is there a way to make S4A autoclose { and ( ?

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 13 Jul 2017, 08:18

Our AutoHotkey webinar on July 18th @ 4 EST went well. Here's a link to the SciTE webinar and resources.

1) Adding Intellisense for additional languages (~80)
2) Tweaking Intellisense to use your file / library
3) Use the Output area as a GUI
4) Customizing your context menu
5) Running multiple instances of SciTE
6) Setting default magnification level
7) Interactive debugging
8) Paste as RTF
9) Change list of extensions to open
10) Move highlighted text up/down
11) Highlight each instance of a word
12) Customize status bar
13) Run selected text
14) Multi-line typing

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 12 Jul 2017, 22:45

Just make it a nice patch-exe? :D

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by evilC » 12 Jul 2017, 16:51

I started a new thread where I provide pre-built versions of Lexikos' version of Scite.
It's still only a ZIP that you have to patch your scite folder with, but it is a more recent version than the one I posted before.
I have still not been able to work out how to modify the installer - I tried replacing the files in the installer (It's just a self-extracting zip) but no dice.
At some point I will try following the installer instructions to build a new one, but I suspect it may not work properly anyway, as I am not sure Lexikos' mods bump the version, so it may try "updating" as it does post-install now, which I guess would wreck everything.
@Lexikos, any thoughts? Also, is my method sound - eg is it OK to just copy source folder over Scite install and ignore instructions to build documentation, add GenDocs etc?

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by sv270190 » 04 Jul 2017, 21:35

Type %var% with minimum key strokes ie key board shortcut for % %

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by sv270190 » 04 Jul 2017, 21:33

How can I get %var% easily

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by WalkerOfTheDay » 16 Jun 2017, 04:49

Well I'm still stuck with the error. Any ideas?

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by tjdickinson » 22 May 2017, 10:31

Latest update...it's back to working again...not quite sure why or how... I'll keep you updated if something changes!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by tjdickinson » 17 May 2017, 03:27

P.S. Unlike WalkerOfTheDay, I don't get any error messages.

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by tjdickinson » 17 May 2017, 03:27

fincs wrote:That is weird. Can you post here the full contents of the registry key HKLM\Software\SciTE4AutoHotkey (or HKLM\Software\WOW6432Node\SciTE4AutoHotkey)? I have a feeling that the installation directory was incorrectly set.


Here's what the registry HKLM\Software\WOW6432Node\SciTE4AutoHotkey contains:
S4AHK Reg.PNG
S4AHK Reg.PNG (13.13 KiB) Viewed 1106 times


fincs wrote:When you open SciTE and it's broken, what is the full process command line of SciTE.exe? (You may have to tweak Task Manager's "Details" tab, by rightclicking on the ListView header, selecting "Select columns" and enabling "Command line").


The Command line says:
"C:\Program Files\AutoHotkey\SciTE\SciTe.exe" "C:\Users\[User]\Documents\..."
Of course, [User] is my username, and the rest of the line is the path to the opened .ahk file.

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by WalkerOfTheDay » 17 May 2017, 02:25

Hi fincs,

I think my toolbar 'exploded too'. Everytime I fire SciTE for the first time I get this
errormessage:

SciTE4.JPG
SciTE4.JPG (49.63 KiB) Viewed 1109 times


And the strange thing is, it happens op two pc's !

After clicking OK, I can still use the software, I just lost some buttons like play / MsgBox Creator / Gui creator etc..

Any ideas ?

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by fincs » 16 May 2017, 12:08

That is weird. Can you post here the full contents of the registry key HKLM\Software\SciTE4AutoHotkey (or HKLM\Software\WOW6432Node\SciTE4AutoHotkey)? I have a feeling that the installation directory was incorrectly set.

When you open SciTE and it's broken, what is the full process command line of SciTE.exe? (You may have to tweak Task Manager's "Details" tab, by rightclicking on the ListView header, selecting "Select columns" and enabling "Command line").

Top