SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post a reply

Confirmation code
Enter the code exactly as it appears. All letters are case insensitive.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :| :mrgreen: :geek: :ugeek: :arrow: :angel: :clap: :crazy: :eh: :lolno: :problem: :shh: :shifty: :sick: :silent: :think: :thumbup: :thumbdown: :salute: :wave: :wtf: :yawn: :facepalm: :bravo: :dance: :beard: :morebeard: :xmas: :HeHe: :trollface: :cookie: :rainbow: :monkeysee: :monkeysay: :happybday: :headwall: :offtopic: :superhappy: :terms: :beer:
View more smilies

BBCode is ON
[img] is OFF
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Re: SciTE4AutoHotkey v3.0.05.01 [Updated April 5 2014]

Post by bighom » 24 May 2018, 03:09

ran88dom99 wrote:So i open SciTE and right away most of the screen bellow toolbar strobes black in sync with the keyboard cursor's off graphic. After a while that goes away and on same off graphic strobe tempo a bunch of lines I clicked on are highlighted as well as ... See picture. Screenshots.7z

Edit; I had autoit scite installed before installing SciTE4AHK. Edit; i mean that is a possible cause not that the problem was solved.


Right click on Scite.exe file and run from other grafic processor

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 25 Jan 2018, 09:05

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by GreatGazoo » 25 Jan 2018, 00:21

joedf wrote:Something might be wrong with your installation... :think:

I used zip for both files, am I missing something ?
Image

I did add copy of AHK U64 to this folder
Image

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 24 Jan 2018, 22:41

Something might be wrong with your installation... :think:

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by GreatGazoo » 24 Jan 2018, 03:36

everything was working fine until i tried to use this editor,

deleted my version 1.1.26 and got the new version 1.1.27 and moved everything to program files x86, put scite in the folder to extracted everything
still dont work im getting this error and none of my scripts work anymore, pretty tired pretty frustrated, works fine after "saving as" .AHK but cant quick launch from within the editor, not really big deal but just confused why I'm having this problem, i really dont want to have to keep navigating thru program files i much rather have this stuff in documents folder

>"C:\Program Files (x86)\AutoHotKey\SciTE4AHK300601_Portable\SciTE\..\AutoHotkey.exe" /ErrorStdOut "C:\Program Files (x86)\AutoHotKey\SciTE4AHK300601_Portable\SciTE\Test.AHK"
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.
>Exit code: 1 Time: 0.2089

this is the code its failing on

Code: [Select all] [Expand]GeSHi © Codebox Plus

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 09 Jan 2018, 15:10

Yes- create a Scite HOME variable. You can see my tutorial here: http://the-automator.com/scite-home-variable/

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Guest » 09 Jan 2018, 12:52

The settings of this program are in the Documents folder. Can I change it somehow to the software's instal folder?

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by GreatGazoo » 05 Jan 2018, 23:33

installer didnt work i think i have a different version of AHK that this cant recognize

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by iPhilip » 05 Jan 2018, 04:16

Joe Glines wrote:I loved the idea and did some Googling. AutoIt had this implemented with SciTE. I just had to make a few very minor tweaks.
The below code will close out: {, [, (, ", and '

Here's what you need to do to try this:
1) Export these lua files into your SciTE home directory
2) Open your UserLuaScript.lua script and add the following lines (in this order)

Code: [Select all]GeSHi © Codebox Plus

-- ***AutoClose Begin***
dofile(props['SciteUserHome'].."/Class.lua")
dofile(props['SciteUserHome'].."/Common.lua")
dofile(props['SciteUserHome'].."/AutoCloseBraces.lua")
EventClass:BeginEvents() -- Start up the events (Calls onstartup()).
-- ***AutoClose END

3) Restart SciTE

Hi Joe,

Thank you for this tip. I found out that:
  1. The line dofile(props['SciteUserHome'].."/Common.lua") (and thus the Common.lua file) is not necessary.
  2. As Ovg mentioned in the above post, this solution breaks the ability to add breakpoints.
Cheers!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by iPhilip » 04 Jan 2018, 17:31

boiler wrote:It's built-in. Press F12.
I was curious where this hotkey is set so I went looking and found more hotkeys by opening SciTE4AutoHotkey, selecting Options and selecting Open tillagoto.properties from the menu. There I found this section:

Code: [Select all] [Expand]GeSHi © Codebox Plus

I played around with these hotkey and found them quite useful, especially when navigating large files. I hope others found this useful.

Cheers!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by j88r » 29 Nov 2017, 00:00

Image
解决中文字符颜色显示为数字问题(Solve the Chinese character color is displayed as a numerical problem)(by google translate)
Image
解决中文字体显示异常问题(Solve the Chinese font display abnormalities)(by google translate)

Code: [Select all]GeSHi © Codebox Plus

#define SCE_AHK_IDENTIFIER 21
Image
解决临近变量格式与变量显示格式相同问题(Solve the variable format and the adjacent variable format display the same problem)(by google translate)
Attachments
img.png
img.png (3.3 KiB) Viewed 1783 times
code2.png
(82.64 KiB) Not downloaded yet
code1.png
(61.79 KiB) Not downloaded yet

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by J Scott Elblein » 10 Nov 2017, 18:43

Any mods/way to auto-open the Variables window when starting a debug session on a script?

Another nice thing would be to have it auto-run when you first start the script. i.e. Normally, you first click the debug icon, then have to click the Run icon. All-in-one click would be cool.

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by J Scott Elblein » 10 Nov 2017, 18:41

Ovg wrote:While this mod is active I can't set breakpoints anymore. Any suggestions will be appreciated.

Same here. It breaks breakpoints. :cry:

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Ovg » 19 Sep 2017, 10:59

While this mod is active I can't set breakpoints anymore. Any suggestions will be appreciated.

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 23 Aug 2017, 14:21

sorry- there should be -- in front of ***Autoclose begin. I've updated it above. :oops:

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by derz00 » 23 Aug 2017, 13:21

Joe Glines wrote:I loved the idea and did some Googling. AutoIt had this implemented with SciTE. I just had to make a few very minor tweaks.
The below code will close out: {, [, (, ", and '

Here's what you need to do to try this:



Hi, I did that, and get this error:

Code: [Select all]GeSHi © Codebox Plus

C:\Users\ZCM\Documents\AutoHotkey\SciTE/UserLuaScript.lua:7: unexpected symbol near '*'
>Lua: error occurred while loading startup script


UserLuaScript.lua looks like this:

Code: [Select all] [Expand]GeSHi © Codebox Plus



***AutoClose Begin*** is line 7, which is the line of error. Any tips what I'm doing wrong??

Edit: Fixed, thanks Joe!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by joedf » 23 Aug 2017, 08:32

Nice share there Joe!

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by Joe Glines » 23 Aug 2017, 07:03

I loved the idea and did some Googling. AutoIt had this implemented with SciTE. I just had to make a few very minor tweaks.
The below code will close out: {, [, (, ", and '

Here's what you need to do to try this:
1) Export these lua files into your SciTE home directory
2) Open your UserLuaScript.lua script and add the following lines (in this order)

Code: [Select all]GeSHi © Codebox Plus

-- ***AutoClose Begin***
dofile(props['SciteUserHome'].."/Class.lua")
dofile(props['SciteUserHome'].."/Common.lua")
dofile(props['SciteUserHome'].."/AutoCloseBraces.lua")
EventClass:BeginEvents() -- Start up the events (Calls onstartup()).
-- ***AutoClose END

3) Restart SciTE

Here's a short video walking through the process

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by mankvl » 23 Aug 2017, 03:21

HotKeyIt wrote:
mankvl wrote:is there a way to make S4A autoclose { and ( ?

Probably:

Code: [Select all]GeSHi © Codebox Plus

#IfWinActive ahk_class SciTEWindow
~(::Send {)}{Left}
#IfWinActive

Ye, just was going to do smth like this, but this will only work if I have my main script running. Anyway thanks :)

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Post by HotKeyIt » 22 Aug 2017, 16:56

mankvl wrote:is there a way to make S4A autoclose { and ( ?

Probably:

Code: [Select all]GeSHi © Codebox Plus

#IfWinActive ahk_class SciTEWindow
~(::Send {)}{Left}
#IfWinActive

Top