[Archived, Locked] Suggestions on documentation improvements

Share your ideas as to how the documentation can be improved.
lexikos
Posts: 9560
Joined: 30 Sep 2013, 04:07
Contact:

Re: Suggestions on documentation improvements

14 Mar 2015, 16:56

if there is already a key in the object and Insert overwrites the value of that key, then Insert doesn't really 'make' the object's base inaccessible
If there's already a "base" key, you already called Insert. Likewise, if you call Remove twice in a row, the second call is going to do nothing.
User avatar
trismarck
Posts: 506
Joined: 30 Sep 2013, 01:48
Location: Poland

Re: Suggestions on documentation improvements

14 Mar 2015, 19:29

Ok, this nails it - thanks.
geek
Posts: 1052
Joined: 02 Oct 2013, 22:13
Location: GeekDude
Contact:

Re: Suggestions on documentation improvements

22 Mar 2015, 12:22

I suggest making "comments in scripts" in the chm index point to the relevant anchor (http://ahkscript.org/docs/Scripts.htm#Comments) instead of just the page (http://ahkscript.org/docs/Scripts.htm)
toralf
Posts: 868
Joined: 27 Apr 2014, 21:08
Location: Germany

Re: Suggestions on documentation improvements

10 Apr 2015, 21:26

1) The docs write:CoordMode, ToolTip|Pixel|Mouse|Caret|Menu [, Screen|Window|Client]
It is leaving out 'Relative' for the second parameter. Is this intended?

2) ObjLength() and TV_SetImageList() aren't in the index.

3) The docs write: Exception(Message [, What, Extra]), But the description of the properties is in a different order. I would suggest to order then in the order of parameters. Putting File and Line at the end and adding for these two the sentence: 'will be set automatically'. Which is kind of obvious when you understand it, but it throw me off when I first read it, because I was trying to find out how I could define them in the parameters. :headwall:

4) The docs write: Until can be used with any Loop or For. But the examples are only using Loop. Maybe adding an example for For would be beneficial.
ciao
toralf
lexikos
Posts: 9560
Joined: 30 Sep 2013, 04:07
Contact:

Re: Suggestions on documentation improvements

11 Apr 2015, 18:47

1) Yes, this has been asked before. Relative was replaced with Window. I do not recommend using the former.
Window: Synonymous with Relative and recommended for clarity.
2 & 3) Thanks.

4) It's not useful very often. You can write an example if you like.
User avatar
joedf
Posts: 8940
Joined: 29 Sep 2013, 17:08
Location: Canada
Contact:

Re: Suggestions on documentation improvements

26 May 2015, 09:20

What if you wanted to use ExludeTitle but not fill in WinText or WinTitle? Simple!
As reported by Mousashi (autohotkey.com)
Under Tutorial (quick start) Section 8a paragraph 5 "ExludeTitle" should be "ExcludeTitle"
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500, NVIDIA GTX 1060 6GB, 2x16GB Kingston FURY Beast - DDR4 3200 MHz | [About Me] | [About the AHK Foundation] | [Courses on AutoHotkey]
[ASPDM - StdLib Distribution] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library]
geek
Posts: 1052
Joined: 02 Oct 2013, 22:13
Location: GeekDude
Contact:

Re: Suggestions on documentation improvements

02 Jun 2015, 09:46

Does anyone else agree that all the <> inequality code in the documentation should be changed to !=?

Example of it being used in an example: http://ahkscript.org/docs/Variables.htm#Expressions
just me
Posts: 9426
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Suggestions on documentation improvements

02 Jun 2015, 09:50

I prefer <>.
User avatar
tidbit
Posts: 1272
Joined: 29 Sep 2013, 17:15
Location: USA

Re: Suggestions on documentation improvements

02 Jun 2015, 09:53

!=

! means not. = means equals. ... not equals
seems to make perfect sense, no?

< means less-than. > means greater-than. ... less-than greater-than
what does that even mean? MAYBE for numbers. But still no. For strings, definitely doesn't make sense.
rawr. fear me.
*poke*
Is it December 21, 2012 yet?
Guest

Re: Suggestions on documentation improvements

02 Jun 2015, 12:24

I also prefer <> I read it as "unequal" not as "less-than greater-than" - I have no proof but I think you see <> more often as opposed to != in the wild (solely based on personal experience, recollection)
just me
Posts: 9426
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Suggestions on documentation improvements

02 Jun 2015, 14:49

@tidbit:
For strings, definitely doesn't make sense.
How do you think are strings compared?
User avatar
joedf
Posts: 8940
Joined: 29 Sep 2013, 17:08
Location: Canada
Contact:

Re: Suggestions on documentation improvements

02 Jun 2015, 19:28

@tidbit hahah good point haha
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500, NVIDIA GTX 1060 6GB, 2x16GB Kingston FURY Beast - DDR4 3200 MHz | [About Me] | [About the AHK Foundation] | [Courses on AutoHotkey]
[ASPDM - StdLib Distribution] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library]
User avatar
nnnik
Posts: 4500
Joined: 30 Sep 2013, 01:01
Location: Germany

Re: Suggestions on documentation improvements

02 Jun 2015, 19:41

For me the decision is easy.
<> is easier to type.
Recommends AHK Studio
User avatar
joedf
Posts: 8940
Joined: 29 Sep 2013, 17:08
Location: Canada
Contact:

Re: Suggestions on documentation improvements

02 Jun 2015, 19:50

:facepalm: :thumbup: lets just leave it as it is... :P
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500, NVIDIA GTX 1060 6GB, 2x16GB Kingston FURY Beast - DDR4 3200 MHz | [About Me] | [About the AHK Foundation] | [Courses on AutoHotkey]
[ASPDM - StdLib Distribution] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library]
just me
Posts: 9426
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Suggestions on documentation improvements

08 Jul 2015, 02:36

ControlGet -> Choice:

The help file provides the following examples:

Code: Select all

SendMessage, 0x188, 0, 0, ListBox1, WinTitle  ; 0x188 is LB_GETCURSEL (for a ListBox).
SendMessage, 0x147, 0, 0, ComboBox1, WinTitle  ; 0x147 is CB_GETCURSEL (for a DropDownList or ComboBox).
ChoicePos = %ErrorLevel%  ; It will be -1 if there is no item selected.
ChoicePos += 1  ; Convert from 0-based to 1-based, i.e. so that the first item is known as 1, not 0.
; It will be -1 if there is no item selected.
is definitely wrong for 32-bit AHK because SendMessage returns an UINT value (4294967295 in this case).
just me
Posts: 9426
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Suggestions on documentation improvements

12 Aug 2015, 04:40

Changes & New Features:
1.1.20.00 - March 8, 2015 - Fixed GuiControl/Get requiring a Gui name when given a control HWND.

GuiControlGet:
Remarks wrote:To operate upon a window other than the default (see below), include its name or number followed by a colon in front of the sub-command ... This is required even if ControlID is a control's associated variable or HWND.
What's true?
geek
Posts: 1052
Joined: 02 Oct 2013, 22:13
Location: GeekDude
Contact:

Re: Suggestions on documentation improvements

12 Aug 2015, 12:02

@just_me It doesn't appear to be true from some tests I did a few days ago, though I didn't test it very thoroughly. I was wondering the same thing by coincidence, because I was using hWnds for the dynamic GUI class I was writing. I have an object method being run by a timer, and inside it has the line

Code: Select all

GuiControl,, % this.hRunButton, &Run ; TODO: Make sure I don't have to specify default gui
If specifying the GUI was required I don't think that'd work at all, but it seems to be working pretty well. The GUI it's operating on is not GUI 1, and I didn't specify Gui, Default anywhere inside the method. It can't be "inheriting" the default GUI from a calling thread since it's being called by timer. This leads me to believe that the documentation is incorrect.

Return to “Suggestions on Documentation Improvements”

Who is online

Users browsing this forum: No registered users and 3 guests