1.1.27 slow on Windows XP

Report problems with documented functionality
guest2

1.1.27 slow on Windows XP

26 Dec 2017, 22:24

AutoHotkey 1.1.27 "Unicode" is slightly slow on Windows XP.
fine with 1.1.26.1 Uni or 1.1.27 Ansi version
I made a following test script.

Code: [Select all] [Expand] [Download] (Untitled.ahk)GeSHi © Codebox Plus



test result:
https://s10.postimg.org/vxmjurkqh/test.png
lexikos
Posts: 6045
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: 1.1.27 slow on Windows XP

27 Dec 2017, 04:39

Try this on v1.1.26.01:

Code: [Select all] [Download] GeSHi © Codebox Plus

t := A_TickCount
Send {vk07} ; Any key (this one has no effect).
MsgBox % A_TickCount-t

Does it take a similar length of time?
guest2

Re: 1.1.27 slow on Windows XP

27 Dec 2017, 21:26

Does it take a similar length of time?

1.1.26.01 ansi = 16
1.1.26.01 uni = 141
1.1.27.00 ansi = 15
1.1.27.00 uni = 16

but the starting of script is more slow in 1.1.27.00 unicode.
all tested in 32bit version.
lexikos
Posts: 6045
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: 1.1.27 slow on Windows XP

28 Dec 2017, 03:38

I dusted the cobwebs off my XP virtual machine and did some testing.

I changed the RunWait line so that the script could be drag-dropped onto an AutoHotkey.exe or started via SciTE:

Code: [Select all] [Download] GeSHi © Codebox Plus

RunWait, "%A_AhkPath%" "%File%"


For starting the script,
1.1.26.01 uni = 20-30
1.1.27.00 uni = 50-60

After adding Send {vk07} to temp.ahk,
1.1.26.01 uni = 50-60
1.1.27.00 uni = 50-60

This is exactly what I expected, unlike your results. I suspect there is something on your system causing this problem, such as antivirus.

The additional delay that my results show is due to some extra work that is done at startup instead of the first time you call Send.
v1.1.27.00 wrote:Improved the odds that Send from a "reg" hotkey such as ^m::Send x will restore the modifier state if Send is being called for the very first time. This makes it less likely to produce a different (and unexpected) result the first time it is held down, such as xmmm instead of xxxx.

This likely has nothing to do with the delay you get, otherwise v1.1.26.01 would show a similar delay the first time you call Send.
guest2

Re: 1.1.27 slow on Windows XP

28 Dec 2017, 20:57

Thanks for your advice, I have the same problem when I turn off antivirus or other programs.
Maybe there is a problem with my environment. (AMD Athlon 64 X2, Windows XP Pro 32bit SP3 Korean or etc.)
I will test it more later.
Thank you once more and have a happy new year.
lexikos
Posts: 6045
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: 1.1.27 slow on Windows XP

30 Dec 2017, 00:34

Do you have more than one keyboard layout active (i.e. installed and available to select with Ctrl+Shift or other keyboard shortcut)?
guest2

Re: 1.1.27 slow on Windows XP

01 Jan 2018, 21:39

Do you have more than one keyboard layout active (i.e. installed and available to select with Ctrl+Shift or other keyboard shortcut)?

Yes exactly.
After removing other input languages (Japanese and Chinese Simplified), the launching of scripts seem faster than before.
1100ms -> 400ms (1.1.27.02 unicode)
lexikos
Posts: 6045
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: 1.1.27 slow on Windows XP

02 Jan 2018, 02:40

With only one input language, how does v1.1.27.02 compare to v1.1.26.01 if the script also calls Send {vk07} (and including Send in the timing)?
guest2

Re: 1.1.27 slow on Windows XP

02 Jan 2018, 04:15

Code: [Select all] [Download] (Untitled.ahk)GeSHi © Codebox Plus

t := A_TickCount
Send {vk07} ; Any key (this one has no effect).
MsgBox % A_TickCount-t

1.1.26.01 uni = 140 ~ 160
1.1.27.02 uni = 15

Code: [Select all] [Download] (Untitled.ahk)GeSHi © Codebox Plus

File := "temp.ahk"
Str := "Send {vk07}"
t := A_TickCount
IfExist, %File%, FileDelete, %File%
FileAppend, %Str%, %File%, UTF-8
RunWait, %File%
If (!ErrorLevel)
MsgBox, % A_TickCount - t

1.1.26.01 uni = 200 ~ 300
1.1.27.02 uni = 200 ~ 300
lexikos
Posts: 6045
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: 1.1.27 slow on Windows XP

16 Jan 2018, 03:55

Please confirm that the v1.1.28.00 preview fixes your startup delay.
guest2

Re: 1.1.27 slow on Windows XP

16 Jan 2018, 22:10

Tested with other input languages (including Chinese Simplified & Traditional, Japanese and Korean) on XP 32bit

Code: [Select all] [Download] GeSHi © Codebox Plus

File := "temp.ahk"
Str := "Send {vk07}"
t := A_TickCount
IfExist, %File%, FileDelete, %File%
FileAppend, %Str%, %File%, UTF-8
RunWait, %A_AhkPath% "%File%"
If (!ErrorLevel)
MsgBox, % A_TickCount - t

1.1.26.1 = 250 ~ 350 msec
1.1.27.6 = 700 ~ 1100 msec
1.1.28.0 preview = 100 ~ 130 msec

It works faster. It is amazing!
Thanks so much

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 5 guests