rALT - a does not work in 1.1.2.27

Report problems with documented functionality
pg4
Posts: 1
Joined: 19 Jan 2018, 19:09

rALT - a does not work in 1.1.2.27

19 Jan 2018, 19:33

works fine in 1.1.24.01 but not in current download. WIN-a works. rALT-a does not. rALT-u/o/s works fine
if I uninstall and revert back to 1.1.24.01 I am back in business. Hence: This should be a bug.

Peter
Attachments
AutoHotkey.ahk
(2.83 KiB) Downloaded 7 times
lexikos
Posts: 5686
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: rALT - a does not work in 1.1.2.27

20 Jan 2018, 18:29

This relates to:
Fixed Send to use the correct modifier state with Unicode chars.

The remapping >!a::ä is roughly equivalent to >!a::Send {Blind}ä, as described on the remapping page.
Send - Blind wrote:When {Blind} is the first item in the string, the program avoids releasing Alt/Control/Shift/Win if they started out in the down position. For example, the hotkey +s::Send {Blind}abc would send ABC rather than abc because the user is holding down the Shift key.
[...]
Blind-mode is used internally when remapping a key. For example, the remapping a::b would produce: 1) "b" when you type "a"; 2) uppercase B when you type uppercase A; and 3) Control-B when you type Control-A.

So in other words, the documented behaviour for >!a::ä is to produce RAlt+ä, and that's what it does in v1.1.27.00+. Similarly, >!a::b always produced RAlt+b, not the letter b.

Your script relies on the previous buggy behaviour to release RAlt before sending the character. Most applications will not print the character if you are holding RAlt. You should simply correct your script to use SendInput for this hotkey the same as you are doing for the other hotkeys.

WIN-a works. rALT-a does not.

Code: [Select all] [Download] GeSHi © Codebox Plus

#a:: Send ä   ; <-- Send
>!a::ä ; <-- No Send

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests