Help File Text Color Using System Defaults

Report problems with documented functionality
SoraHjort
Posts: 6
Joined: 13 Sep 2017, 17:31

Help File Text Color Using System Defaults

Post by SoraHjort » 23 Jan 2018, 17:30

A minor issue with the help files is that it inherits several text colors from the system's appearance setting.
This is a problem for people who use a dark color scheme, as in light text on dark background. The main offender is the primary text color which is normally black. However other colors such as those for Hyperlinks have been noticed as well.
This was tested with version 1.1.27.07 of AHK, as well as on Windows Vista and Windows 7.
In the example image below you can see how this may affect readability, as that color is normally on a much darker color.

Image

This has been a problem with the help file for some years, but unfortunately I just ignored it and used the web version instead of reporting it. But when I recently updated (it had been a while) and saw the new help file setup, I figured it was time for me to stop being lazy and report the issue.
User avatar
Ragnar
Posts: 200
Joined: 30 Sep 2013, 15:25

Re: Help File Text Color Using System Defaults

Post by Ragnar » 23 Jan 2018, 19:28

SoraHjort
Posts: 6
Joined: 13 Sep 2017, 17:31

Re: Help File Text Color Using System Defaults

Post by SoraHjort » 23 Jan 2018, 19:46

Ragnar wrote:This issue is already known. See https://autohotkey.com/boards/viewtopic ... 18#p195518.
It was not reported in the bug reports, but on the Wishlist board. Which is why that doesn't show up when you do an advance search on a specific board.
Besides, it really should have been put onto the bug reports for visibility.
Post Reply

Return to “Bug Reports”