hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

Report problems with documented functionality
20170201225639
Posts: 27
Joined: 01 Feb 2017, 22:57

hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

17 Aug 2018, 11:27

Version Number: 1.1.29.01

Problem: when I turn on the X (execute) option, usually I can put "Send ___" immediately after the hotstring with no linebreak & return and have this trigger the execution of a Send command rather than text replacement. However in the case where what is being sent contains the grave accent, nothing happens and I must revert to using three lines of code.

In other words, this

Code: Select all

#Hotstring * B0 ? X
::cs::Send ^``
doesn't work (doesn't send ctrl+accent). However if you change it to

Code: Select all

#Hotstring * B0 ? X
::cs::
Send ^``
return
it WILL work (although it defeats the purpose of turning on X option).

Thank you!
swagfag
Posts: 1384
Joined: 11 Jan 2017, 17:59

Re: hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

17 Aug 2018, 12:36

dont have the time to dig into that rn.
use this workaround:

Code: Select all

#Hotstring * B0 ? X
::cs::Send ^{vkC0}
User avatar
jeeswg
Posts: 5289
Joined: 19 Dec 2016, 01:58
Location: UK

Re: hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

17 Aug 2018, 17:47

I thought I might mention this problem re. using `s in hotstrings in AHK v2.

Code: Select all

:*:abc::a`sb`sc`s ;not working correctly
:*:def::d`te`tf`t
:*:ghi::g h i `

;results:
;asbscs
;d	e	f
;g h i
guest3456
Posts: 2438
Joined: 09 Oct 2013, 10:31

Re: hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

17 Aug 2018, 18:29

I thought I might mention this problem re. using `s in hotstrings in AHK v2.

Code: Select all

:*:abc::a`sb`sc`s ;not working correctly
:*:def::d`te`tf`t
:*:ghi::g h i `

;results:
;asbscs
;d	e	f
;g h i
https://lexikos.github.io/v2/docs/misc/EscapeChar.htm

lexikos
Posts: 6207
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: hotstring X (execute) option doesn't work for sending anything containing accents (Autohotkey_L)

11 Nov 2018, 02:01

v1.1.30.01 fixes escape sequences in one-line executable hotstrings.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests