Forum really really slow...

Discuss issues and requests related with the forum software
jballi
Posts: 515
Joined: 29 Sep 2013, 17:34

Forum really really slow...

24 Feb 2017, 22:01

At least for me. Sometimes takes over a minute to do anything.
SOTE
Posts: 181
Joined: 15 Jun 2015, 06:21

Re: Forum really really slow...

25 Feb 2017, 01:57

Same for me. The forum and website are extremely slow.
User avatar
Nextron
Posts: 1273
Joined: 01 Oct 2013, 08:23
Location: Netherlands OS: Win7 x64 AHK: Unicode x32

Re: Forum really really slow...

25 Feb 2017, 03:47

It appears to be content with Cache-Control:"private, no-cache="set-cookie", no-cache" that's taking its time. So that's when Cloudflare connects to the actual AHK webhost?
2017-02-25_9-34-27.png
2017-02-25_9-34-27.png (104.01 KiB) Viewed 6550 times
guest56456456546456

Re: Forum really really slow...

25 Feb 2017, 15:39

It's going fast for me again, now.. I hope it stays that way
User avatar
joedf
Posts: 6600
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada, Quebec
Contact:

Re: Forum really really slow...

25 Feb 2017, 16:24

We had a huge spike of 624 users on feb24,2017...
I'm not sure how Cloudflare is set up. Tank is the one with acess to it.
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 3.00 GHz, 16GB DDR4 3200 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
jballi
Posts: 515
Joined: 29 Sep 2013, 17:34

Re: Forum really really slow...

25 Feb 2017, 17:19

Some improvement lately but I'm still getting a "Error 524 - A timeout occurred" occasionally when performing a search.
User avatar
Capn Odin
Posts: 1290
Joined: 23 Feb 2016, 19:45
Location: Denmark

Re: Forum really really slow...

25 Feb 2017, 18:29

I don't know if this is related, but I just spent 49 sec not getting a gif when opening the main forum page. I have been experiencing long load times the last couple of days, but not consistently.

It doesn't seem like it's needed, but I'm probably wrong.

I don't know how accurate the visitor count is, but it said 200+.
Spoiler
Please excuse my spelling I am dyslexic.
SOTE
Posts: 181
Joined: 15 Jun 2015, 06:21

Re: Forum really really slow...

25 Feb 2017, 19:45

Possibly Cloudfare has something to do with it. Was getting this error sometimes too. It's troubling to see that AutoHotKey's website constantly has problems like this. Going on for years now, and being difficult to reach for many days at a time. It's very hard on users trying to lookup info.

Interesting article about Cloudflare. https://tech.tiq.cc/2016/01/why-you-sho ... loudflare/

Error 524 • 2017-02-25 19:41:13 UTC
A timeout occurred

It would graphically show that Cloudfare could not connect to AutoHotKey.com
Image
just me
Posts: 5574
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Forum really really slow...

26 Feb 2017, 02:32

Hi tank, are you working on this issue? If so, it would be nice to get an interim report.
imustbeamoron
Posts: 41
Joined: 18 Aug 2016, 22:56

Re: Forum really really slow...

26 Feb 2017, 14:41

real slow here too.. takes over a minute to load anything.. hoping for a quick resolution. thanks
User avatar
joedf
Posts: 6600
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada, Quebec
Contact:

Re: Forum really really slow...

26 Feb 2017, 16:38

Interesting article. I've sent tank a notification on facebook. Not sure If he's available at the moment.
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 3.00 GHz, 16GB DDR4 3200 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
just me
Posts: 5574
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: Forum really really slow...

27 Feb 2017, 03:43

So server administration is still a one man show and for several days nobody knows whether this one man is available? That's commonly called SinglePointOfFailure. IMHO, this must not be.

I needed about six minutes to login, to navigate to this thread, and to post this answer.
User avatar
nnnik
Posts: 3453
Joined: 30 Sep 2013, 01:01
Location: Germany

Re: Forum really really slow...

27 Feb 2017, 06:01

Yeah it just took me 20.
We need to disable cloudflare.
Most access is shared with at least 2 people. But not everything - we need to fix that.
Recommends AHK Studio
User avatar
tank
Posts: 2401
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: Forum really really slow...

27 Feb 2017, 09:16

i dont see any elavated threats but am still investigating
I rebooted the server this morning
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
User avatar
tank
Posts: 2401
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: Forum really really slow...

27 Feb 2017, 09:22

I have also temporarily increased the hardware till i can investigate more completely
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
guest3456
Posts: 2433
Joined: 09 Oct 2013, 10:31

Re: Forum really really slow...

27 Feb 2017, 10:21

So server administration is still a one man show and for several days nobody knows whether this one man is available? That's commonly called SinglePointOfFailure. IMHO, this must not be.
What do you propose? Do you want the responsibility of being a server administrator? Remember these are volunteers

User avatar
tank
Posts: 2401
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: Forum really really slow...

27 Feb 2017, 11:32

We need to disable cloudflare.
Not a cloudflare problem at all in fact a surge in legit user activity pegging the CPU

So server administration is still a one man show and for several days nobody knows whether this one man is available?
That is actually un true. JoeDF and I had a conversation and i suggested waiting for me to do it. Lexikos JoeDF and I all have the exact same access. the difference is of course one of us doesnt have to google everything and experiment as much. We both wanted to see if this was a short temp problem before taking radical action. While it is true i was busy with life if this was to be a very short lived problem there was no need to increase server capacity. Also i have more experience with the server logs.
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
SOTE
Posts: 181
Joined: 15 Jun 2015, 06:21

Re: Forum really really slow...

27 Feb 2017, 12:54

Glad it was solved, but the server was like basically down for around 4 days. And if the solution was just to reboot the server, that does seems like a long time to take that action. Such a time period could be very frustrating to many AutoHotkey users. Particularly if there is a surge in enthusiastic people wanting to get info on AutoHotkey, but then can't access the site for days.
User avatar
tank
Posts: 2401
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: Forum really really slow...

27 Feb 2017, 13:21

it was not a simple reboot. I actually performed a server upgrade this morning. Apologies i knew about it only 2 days. My Facebook account is linked publicly in my profile and i welcome messages if there are server issues
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
User avatar
Nextron
Posts: 1273
Joined: 01 Oct 2013, 08:23
Location: Netherlands OS: Win7 x64 AHK: Unicode x32

Re: Forum really really slow...

27 Feb 2017, 13:30

GJ for fixing it tank! I missed the docs.. I expected those to be accessible as Cloudflare can easily cache that static stuff.
We had a huge spike of 624 users on feb24,2017...
I'm curious whether that's coincidence, malintent or AHK was featured on some other site (>referer log).

Return to “Forum Issues”

Who is online

Users browsing this forum: No registered users and 6 guests