command links in codeboxes are broken

Discuss issues and requests related with the forum software
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

command links in codeboxes are broken

15 Feb 2018, 09:23



click those command links above, it takes you to the docs site, but the helppage is in a mini frame

tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: command links in codeboxes are broken

15 Feb 2018, 09:28

Not for me? what browser?
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

15 Feb 2018, 09:32

tankuser wrote:Not for me? what browser?


chrome 64.0.3282.167

but it looks like its not the link issue from the codebox, but rather all the docs pages:

https://autohotkey.com/docs/commands/IfIn.htm

tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: command links in codeboxes are broken

15 Feb 2018, 09:35

it all appears normal to me?? I too am using the latest Chrome
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

15 Feb 2018, 10:01

tankuser wrote:it all appears normal to me?? I too am using the latest Chrome


not sure.. i did just update Chrome yesterday. are you using the exact same version number? i'm on win10 64bit. it does look fine in firefox and edge

tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: command links in codeboxes are broken

15 Feb 2018, 12:21

guest3456 wrote:
tankuser wrote:it all appears normal to me?? I too am using the latest Chrome


not sure.. i did just update Chrome yesterday. are you using the exact same version number? i'm on win10 64bit. it does look fine in firefox and edge
Version 63.0.3239.132 OH!! IC
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

15 Feb 2018, 12:46

tankuser wrote:Version 63.0.3239.132 OH!! IC


so if you update, can you confirm the broken docs pages too?

User avatar
Xtra
Posts: 1188
Joined: 02 Oct 2015, 12:15

Re: command links in codeboxes are broken

15 Feb 2018, 13:10

Google Chrome is up to date
Version 64.0.3282.167 (Official Build) (64-bit)

Works here
User avatar
gregster
Posts: 1346
Joined: 30 Sep 2013, 06:48

Re: command links in codeboxes are broken

15 Feb 2018, 14:30

Yeah, works for me, too, on Win10 64 bit with latest Chrome 64 bit version.
tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: command links in codeboxes are broken

15 Feb 2018, 15:05

guest3456 wrote:so if you update, can you confirm the broken docs pages too?
Updates prevented by admin :(
User avatar
Masonjar13
Posts: 1352
Joined: 20 Jul 2014, 10:16
GitHub: Masonjar13
Location: Не Россия

Re: command links in codeboxes are broken

15 Feb 2018, 23:07

This is a loading issue. I'm unsure of where in the loading it actually occurs, but I've had this happen (Firefox). After refreshing, it was back to normal.
User avatar
Ragnar
Posts: 186
Joined: 30 Sep 2013, 15:25

Re: command links in codeboxes are broken

16 Feb 2018, 08:50

Since v1.1.28, the sidebar uses a frame to speed up the navigation in the docs, just like the offline help.

In short, when a page such as https://autohotkey.com/docs/commands/EnvSub.htm opens for the first time, you will automatically be redirected to https://autohotkey.com/docs/frame.htm#c ... EnvSub.htm.

Your issue is a timing issue which results in a script error. Open the DevTools (press F12), go to the console tab and you'll see something like "Cannot read property 'en' of undefined".

I'll fix this.

Edit: Now I can't reproduce this issue anymore. Maybe due to cloudflare?
User avatar
tank
Posts: 2306
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: command links in codeboxes are broken

16 Feb 2018, 17:03

I can disable cloudflare caching for a couple of days if it helps
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

17 Feb 2018, 08:20

Ragnar wrote:Since v1.1.28, the sidebar uses a frame to speed up the navigation in the docs, just like the offline help.

In short, when a page such as https://autohotkey.com/docs/commands/EnvSub.htm opens for the first time, you will automatically be redirected to https://autohotkey.com/docs/frame.htm#c ... EnvSub.htm.

Your issue is a timing issue which results in a script error. Open the DevTools (press F12), go to the console tab and you'll see something like "Cannot read property 'en' of undefined".

I'll fix this.

Edit: Now I can't reproduce this issue anymore. Maybe due to cloudflare?


yes, i was seeing that redirect in the nav bar

curiously, the problem seems to have disappeared for me

guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

24 Feb 2018, 11:40

problem is back :(

i can't even get to the main docs page:

https://autohotkey.com/docs/

User avatar
tank
Posts: 2306
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: command links in codeboxes are broken

24 Feb 2018, 11:56

Think this is a different problem. Work in on it
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

24 Feb 2018, 12:17

seems like the same "frame" problem that Ragnar talked about above

User avatar
tank
Posts: 2306
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: command links in codeboxes are broken

24 Feb 2018, 14:11

On mobile chrome frames load but no content
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
guest3456
Posts: 2353
Joined: 09 Oct 2013, 10:31

Re: command links in codeboxes are broken

25 Feb 2018, 00:53

from the other thread, clearing the Chrome cache files has resolved the frame redirect problem

User avatar
tank
Posts: 2306
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Louisville KY
Contact:

Re: command links in codeboxes are broken

25 Feb 2018, 00:55

Not for me
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request

Return to “Forum Issues”

Who is online

Users browsing this forum: No registered users and 2 guests