Number := NumGet(VarOrAddress [, Offset := 0][, Type := "UPtr"])and
NumPut Number, VarOrAddress [, Offset := 0][, Type := "UPtr"].
- Remove the 'Offset' parameter. This parameter is totally unnecessary, just use 'Address + Offset'.
- Change 'VarOrAddress' to accept only 'Address'. I think this creates a huge confusion in trying to interpret the code, besides being one of the things that makes, in my opinion, a bad language.
- This would increase performance, since AutoHotkey would not have to do (I think) such a check.
- It makes the language clearer and easier to interpret, and you do not have to guess if you are passing the memory address of the variable or the address that contains the variable.
- Reduces unnecessary parameters and source code size.
- Makes it to be consistent with StrGet/StrPut.
- ... ... ?
What do you think?
I would like to add a question, which has nothing to do with the main theme (but anyway...): Why was "UInt64" never implemented?