v2.0-a094 Missing "}" Error! when build with VS2017 Topic is solved

Discuss the future of the AutoHotkey language
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

v2.0-a094 Missing "}" Error! when build with VS2017

27 Apr 2018, 07:12

v2.0-a094 not supporting define function as follow

Wish to keep such syntax legally! :(
Last edited by aseiot on 27 Apr 2018, 07:58, edited 2 times in total.
User avatar
Flipeador
Posts: 801
Joined: 15 Nov 2014, 21:31
GitHub: Flipeador
Location: Argentina
Contact:

Re: v2.0-a094 Missing "}" Error!

27 Apr 2018, 07:13

Works for me... 2.0-a094-29bbc64


Edit
Try to build from the source with VS2017(SDK 8.1 and Visual Studio 2017 v141)

You're right... :think:
Spoiler
Windws 1♂ Pro 64-Bits I make scripts for AHKv2 (my v2 compiler) & WIN_7+ Spanish Argentina SublimeText 3 & AHKv2
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

Re: v2.0-a094 Missing "}" Error!

27 Apr 2018, 07:31

Flipeador wrote:Works for me... 2.0-a094-29bbc64

Yes, you are right! Seems problem of my custom build. I will try to figure it out. Thanks!
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

Re: [Solved] v2.0-a094 Missing "}" Error!

27 Apr 2018, 07:56

Try to build from the source with VS2017(SDK 8.1 and Visual Studio 2017 v141). Unfortunately, the build still not work for me! After revert following commit, it works again!
Improved error reporting for unbalanced ()/[]/{}.2cd2354

Please help!
Helgef
Posts: 2992
Joined: 17 Jul 2016, 01:02
Contact:

Re: [Solved] v2.0-a094 Missing "}" Error!

27 Apr 2018, 08:01

How to Compile wrote:AutoHotkey is developed with Microsoft Visual Studio Community 2015 Express

Cheers
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

Re: [Solved] v2.0-a094 Missing "}" Error!

27 Apr 2018, 08:23

Helgef wrote:
How to Compile wrote:AutoHotkey is developed with Microsoft Visual Studio Community 2015 Express

Cheers

I know that. I had build with VS2017 for awhile, it works until now!

PS: following statement works for me.


So, I initially misconceive changing for syntax!
User avatar
nnnik
Posts: 2910
Joined: 30 Sep 2013, 01:01
Location: Germany

Re: v2.0-a094 Missing "}" Error! when build with VS2017

27 Apr 2018, 09:58

As far as I remember I had issues with Visual Studio 2017 building AutoHotkey due to the absence of a specific build tool.
how did you manage to work around that issue - or does Visual Studio have that in the latest build?
Recommends AHK Studio
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

Re: v2.0-a094 Missing "}" Error! when build with VS2017

27 Apr 2018, 19:59

nnnik wrote:As far as I remember I had issues with Visual Studio 2017 building AutoHotkey due to the absence of a specific build tool.
how did you manage to work around that issue - or does Visual Studio have that in the latest build?

Can not remember the detail, but VS2007 offers an option to download required build tools.
lexikos
Posts: 5943
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: v2.0-a094 Missing "}" Error! when build with VS2017  Topic is solved

28 Apr 2018, 00:11

The alpha branch was behind v2.0-a094 by one commit; the one that fixes OTB, 29bbc64, the same one that the v2.0-a094 tag refers to. If you checked out alpha before this post, it was not actually v2.0-a094.
User avatar
aseiot
Posts: 11
Joined: 05 Mar 2017, 04:25

Re: v2.0-a094 Missing "}" Error! when build with VS2017

28 Apr 2018, 00:28

lexikos wrote:The alpha branch was behind v2.0-a094 by one commit; the one that fixes OTB, 29bbc64, the same one that the v2.0-a094 tag refers to. If you checked out alpha before this post, it was not actually v2.0-a094.

Many thanks! It is ok now :D

Return to “AutoHotkey v2 Development”

Who is online

Users browsing this forum: No registered users and 3 guests