Browser_Home behaves restively

Get help with using AutoHotkey and its commands and hotkeys
1701Enterprise
Posts: 2
Joined: 14 Mar 2017, 08:54

Browser_Home behaves restively

14 Mar 2017, 09:32

I have a Cherry MX 3.0 Keyboard which has a key called Browser_Home. Normally it would open the default Browser.
What the keyboard does not have are keys to pause and skip Music, so I decided to use the Browser_Home key together with Volume_Up, -Down and -Mute to fire Media_Next, -Prev and -Play_Pause.

Problem is, the following code does only work occasionally:

Code: [Select all] [Expand] [Download] (Untitled.ahk)GeSHi © Codebox Plus


Sometimes, this works just fine, I press Browser Home and Volume_Up and a currently played song is skipped and so on.
Then it happens that the functions are kind of inverted: Holding Browser_Home and pressing Volume_Up the Volume goes up while without Browser_Home the song is skipped.
Also from time to time pressing Browser_Home alone opens the browser, which I wanted the script to prevent.

Apparently Browser_Home is fired as soon as the button is pressed, not on release, maybe thats important :)
GEV
Posts: 466
Joined: 25 Feb 2014, 00:50

Re: Browser_Home behaves restively

14 Mar 2017, 10:08

1701Enterprise wrote:Apparently Browser_Home is fired as soon as the button is pressed, not on release, maybe thats important

Try

Code: [Select all] [Download] (Untitled.ahk)GeSHi © Codebox Plus

$Browser_Home::
KeyWait, Browser_Home
Return
$Browser_Home Up::Return

Browser_Home & Volume_Down:: send {Media_Prev}
; ...
1701Enterprise
Posts: 2
Joined: 14 Mar 2017, 08:54

Re: Browser_Home behaves restively

20 Mar 2017, 11:19

It got better, but from time to time the described problems still occur. Thank you anyway

Return to “Ask For Help”

Who is online

Users browsing this forum: kczx3 and 35 guests