failure using function keys

Get help with using AutoHotkey and its commands and hotkeys
rayhill1
Posts: 2
Joined: 09 Feb 2018, 13:10

failure using function keys

Post by rayhill1 » 09 Feb 2018, 13:40

I am trtying to use autohotkey on both a W7 and W10 system. To start with I only want to use the Function keys and assign common entry values to them.

On my w7 system I have a number of keys set up: e.g.

F12::
Send, ray@rayhill1.force9.co.uk
Return

F10::
Send, 01808521282
Return

The snag is that F12 works while F10 doesn't.

On the W10 system they don't work at all

Any suggestions would be very welcome
BoBo
Posts: 2515
Joined: 13 May 2014, 17:15

Re: failure using function keys

Post by BoBo » 09 Feb 2018, 13:58

Code: Select all

~F12::Send, ray@rayhill1.force9.co.uk
~F10::Send, 01808521282
Not tested.
TheManiacNextDoor

Re: failure using function keys

Post by TheManiacNextDoor » 09 Feb 2018, 14:37

Working on my end, maybe its prob on ur pc. Try creating new script file, restarting the script/pc. Btw to use those return you have to have ur script like this

Code: Select all

F12::
Send, ray@rayhill1.force9.co.uk{return}

F10::
Send, 01808521282{return}
Gl
Cyber
Posts: 1
Joined: 09 Feb 2018, 14:25

Re: failure using function keys

Post by Cyber » 09 Feb 2018, 14:46

Try making a new script file and use this code

Code: Select all

F12::Send ray@rayhill1.force9.co.uk{return}
F10::Send 01808521282{return}
Tested...nd remove the "{return}" if you don't want the enter key pressed at the end
User avatar
Nextron
Posts: 1218
Joined: 01 Oct 2013, 08:23
Location: Netherlands OS: Win7 x64 AHK: Unicode x32

Re: failure using function keys

Post by Nextron » 09 Feb 2018, 18:22

BoBo wrote:

Code: Select all

~F12::Send, ray@rayhill1.force9.co.uk
~F10::Send, 01808521282
Not tested.
Although that does force the uses of the hook, which would eliminate interfering registered hotkeys by other applications, it does pass though the native function (like F10 activating the menu bar, which is likely not what you want, when inputting text.

So I'd suggest using $ instead of ~.
Post Reply

Return to “Ask For Help”