ControlGetPos does not find RATINGS control in PROPERTIES window

Get help with using AutoHotkey and its commands and hotkeys
joefiesta
Posts: 153
Joined: 24 Jan 2016, 13:54

ControlGetPos does not find RATINGS control in PROPERTIES window

18 Aug 2018, 12:58

In this script, I am trying to "mechanically" set a value for a RATINGS for a file. I open a file's PROPERTIES, click the DETAILS tab, find the position of the RATINGS (the 5 stars) control and click the appropriate star.

(Please don't change the issue and tell me I should be doing this "programmatically" unless can you tell me how, because I have not found a way to do so.)

To see what I am doing, make these changes to my script: 1. Change the fileid to a .JPG file you have. 2. Change the DETX and DETY (detailsX and detailsY) values to match coordinates of the approximate center of the DETAILS tab when you open a PROPERTIES window for your .JPG.

If things go the same for you as me, you will get error 24, msgid 607e. In the script I try two methods to get the position of the RatingsControl1 control. Neither works for me. Errormsg 607E shows the variables which have not been set as expected.

While the error msgbox is being displayed, you can start WinSpy and validate that indeed the position and size of the RatingsControl1 control can be determined.

Why does my ControlGetPos command not work while WinSpy can get the information I want?

Code: [Select all] [Expand] [Download] GeSHi © Codebox Plus

Return to “Ask For Help”

Who is online

Users browsing this forum: anobayan, Coder, newbieforever, shgilad81 and 88 guests