GDI+ standard library 1.45 by tic

Post your working scripts, libraries and tools
guest3456
Posts: 2121
Joined: 09 Oct 2013, 10:31

Re: GDI+ standard library 1.45 by tic

15 Nov 2017, 12:12

nnnik wrote:I think instead of waiting for them it would be faster to implement AHK v1.1 backwards compatability.


i will start to work on it.

User avatar
tidbit
Posts: 1015
Joined: 29 Sep 2013, 17:15
Location: USA

Re: GDI+ standard library 1.45 by tic

15 Nov 2017, 12:55

nnnik, you deleted the wrong link, you're lucky the old forum still has gdip_all.
https://autohotkey.com/board/topic/2944 ... 45-by-tic/
rawr. fear me.
*poke*
Is it December 21, 2012 yet?
User avatar
nnnik
Posts: 2406
Joined: 30 Sep 2013, 01:01
Location: Germany

Re: GDI+ standard library 1.45 by tic

15 Nov 2017, 13:52

Fixed
Recommends AHK Studio
guest3456
Posts: 2121
Joined: 09 Oct 2013, 10:31

Re: GDI+ standard library 1.45 by tic

15 Nov 2017, 15:54

just for reference for people reading:

tic's original:
https://github.com/tariqporter/Gdip/blo ... r/Gdip.ahk

Rseding's unicode and x64 Gdip_All fixes:
https://www.dropbox.com/s/0e9gdfetbfa8v0o/Gdip_All.ahk

AHK v2 version (now also backward compatible with v1 thanks to @nnnik):
https://github.com/mmikeww/AHKv2-Gdip

JoeSchmoe
Posts: 28
Joined: 08 Dec 2014, 08:58

Re: GDI+ standard library 1.45 by tic

03 Jan 2018, 19:26

guest3456 wrote:just for reference for people reading:

tic's original:
https://github.com/tariqporter/Gdip/blo ... r/Gdip.ahk

Rseding's unicode and x64 Gdip_All fixes:
https://www.dropbox.com/s/0e9gdfetbfa8v0o/Gdip_All.ahk

AHK v2 version (now also backward compatible with v1 thanks to @nnnik):
https://github.com/mmikeww/AHKv2-Gdip


Thanks. I found the following, taken from the last github link above, to be helpful in interpreting the above. I reproduce it here for reference:
History
  • @tic created the original Gdip.ahk library
  • @Rseding91 updated it to make it compatible with unicode and x64 AHK versions and renamed the file Gdip_All.ahk
  • this repository updates @Rseding91's Gdip_All.ahk to make it compatible with AHK v2
JoeSchmoe
Posts: 28
Joined: 08 Dec 2014, 08:58

Re: GDI+ standard library 1.45 by tic

03 Jan 2018, 19:29

Am I correct in understanding that everyone should use the mmikeww AHKv2-Gdip version? It seems to be the most compatible. (I actually use AHK 1.1)
guest3456
Posts: 2121
Joined: 09 Oct 2013, 10:31

Re: GDI+ standard library 1.45 by tic

03 Jan 2018, 20:11

JoeSchmoe wrote:Am I correct in understanding that everyone should use the mmikeww AHKv2-Gdip version? It seems to be the most compatible. (I actually use AHK 1.1)


That is meant to be used for AHK v2, but it should also be compatible with AHK 1.1. You can use that or you can use the normal Gdip_All.ahk, which ever you choose


Return to “Scripts and Functions”

Who is online

Users browsing this forum: No registered users and 13 guests