AutoGUI 1.2.0 works for me, but not 1.3.x Topic is solved

Discuss the AutoGUI IDE with a GUI designer and a script editor.
Dan

AutoGUI 1.2.0 works for me, but not 1.3.x

13 Apr 2017, 14:26

I just downloaded AutoGUI 1.3.5 and at first thought that I had set something up incorrectly. But I tried some older versions and found that AutoGUI stops working on my setup between versions 1.2.0 and 1.3.0. (I might not have gone that far, except that I used an even earlier version at one point on another machine, and know it is worth it to try to figure this out.)

The text I get is the following. I captured it with ABBYY Screenshot Reader and then proofread it briefly, so it may not be perfect. (It would be handy to be able to copy/paste from an AHK error message!)

Error in #include file
"C:\Users\[...]\AutoGUI-1.3.5\AutoGUl\lnclude\Properties.ahk":
Parameter #2 invalid.

Specifically: Tab3

Line#
008 {
009 ClassNNList .= g[ltem].CIassNN . "|"
010 }
012 Gui,Add,Picture,gBlinkControlBorder x12 y13 w16 h16
Icon5,IconLib
013: Gui,Add,DropDownList,hWndhCbxClassNN vCbxClassNN
gOnDropDownChange x40 y12 w203,"Window||". ClassNNList
014: Gui,Add,Button,hWndhReloadBtn gReloadSub x248 y11 w23
h23
015: GuiButtonlcon(hReloadBtn, IconLib, 90, "L1 T1")
—> 017: Gui,Add,Tab3,hWndhPropTab vCurrentTab x6 y41 w270 h303
AltSubmit %g_ThemeFix%,General|Options|Window|Events|Script

The program will exit.


I'm using Windows 10. Otherwise, I'm not sure what to add that's relevant about my setup. I use AutoHotkey frequently, and the samples included with AutoGUI do work. As I said, version 1.2.0 also seems to work fine.

More generally speaking, I wonder whether there's a way to trap this error in a way that a little more pleasant-looking for the user, too...

Thanks for your efforts. I'm sure I can get by with 1.2.0 for the time being.

Have a good one,
Dan
kon
Posts: 1760
Joined: 29 Sep 2013, 17:11

Re: AutoGUI 1.2.0 works for me, but not 1.3.x  Topic is solved

13 Apr 2017, 15:55

The error points to line 17 and says that parameter #2 is invalid. Parameter #2 on that line is "Tab3" (also it says "Specifically: Tab3").
Long story short: Tab3 was added to AHK relatively recently, so you might need to update AHK.

Also, you can copy the text from an AHK error message: press Ctrl+C
Dan

Re: AutoGUI 1.2.0 works for me, but not 1.3.x

14 Apr 2017, 11:10

Thank you for the response. Although in retrospect it seems like such an obvious solution that I should have thought of it, I'm not used to software taking advantage of new programming language features so quickly, so that hadn't occurred to me. However, for this software, it does sense that it would be taking advantage of these features more quickly.

My version of AHK was indeed a little (not a lot) outdated. And AutoGUI works perfectly now.

I feel better about this, too, because it means that there isn't some odd glitch in AHK or AutoGUI that is hard to reproduce.

Tab3 was added in version 1.1.24.00 of AHK, released on May 22, 2016. It was then polished over the next few months. The last mention of it is in version 1.1.24.03 from November 19, 2016. So, pretty recent, in terms of a programming language update.

As far as an error trap, is it possible to produce a message to remind people to update to a recent version of AHK? Or perhaps just to remind people in the SourceForge description? Others may not be as boneheaded as me, but that simple reminder might be helpful. Because my AHK was literally from 2016, this isn't something that had even occurred to me, although since AutoGUI is a development tool, it probably should have.

Also, I hope this was an appropriate place to leave this report. There is a place for tickets on SourceForge, but I wasn't sure that it was active.

Thanks for the great work.

Dan

p.s. I did try Ctrl-C to copy the error message. Maybe that's another feature that has been added in a recent version? Or perhaps my C key just didn't work.

Return to “AutoGUI”

Who is online

Users browsing this forum: No registered users and 2 guests