Syntax highlighting gone

The popular SciTE-based AutoHotkey Script Editor
User avatar
chazcon
Posts: 17
Joined: 03 Aug 2015, 23:12

Syntax highlighting gone

27 May 2018, 12:31

So I have been using this distro for years and it works flawlessly.

However yesterday I installed v. 1.1.29.00 of AHK and also from the SciTE official site this Windows installer: An installer created by Troy Simpson.

...thinking I was updating both programs to the latest version, but I found my syntax highlighting was gone.

So I uninstalled SCITE (and beware, that Windows distro closes Windows Explorer and causes a black crash on uninstall)

Cleaned out all SciTE references, reboot and clean install of this distro but with AHK v. 1.1.29.00

...still no syntax highlighting. Ugh what have I done? Need my Scite4AHK back.
FOR THE VITAE!
User avatar
chazcon
Posts: 17
Joined: 03 Aug 2015, 23:12

Re: Syntax highlighting gone

27 May 2018, 14:14

gregster thanks but I have all that - the (strange) issue is that syntax highlighting is gone - opening a .ahk file shows all plain text.

Is this an issue with the 1.1.29.00 version of AHK? Does SciTE4AHK not support the latest version of AHK? Anyone running SciTE successfully (with syntax highlighting) with the 1.1.29.00 version of AHK?
FOR THE VITAE!
User avatar
chazcon
Posts: 17
Joined: 03 Aug 2015, 23:12

Re: Syntax highlighting gone

27 May 2018, 14:43

Ok I uninstalled Autohotkey and Scite4AHK, cleared out all bits, rebooted, clean install of previous version AHK 1.1.26.01 and SciTE4AHK.

Same issue, no syntax highlighting. So frustrating.
FOR THE VITAE!
User avatar
chazcon
Posts: 17
Joined: 03 Aug 2015, 23:12

Re: Syntax highlighting gone

27 May 2018, 22:56

SOLVED

Clean install of Windows 10. Yep. When I installed SciTE4AHK it even updated, never did that before.

HAPPY DANCE
FOR THE VITAE!

Return to “SciTE4AutoHotkey”

Who is online

Users browsing this forum: No registered users and 4 guests